[Resolved] Slow loading of Website and Client Account Area

Started on December 16, 2021 at 8:35 PM. Resolved after 30 minutes

Affected

Core Services
Servercheap Website
Core Services
Client Portal
  • Investigating
    December 16, 2021 at 8:35 PM

    We are aware of an issue causing our website and client area services to load slow or time out. This issue is connected to our CDN provider Cloudflare, and they are actively working on fixing it. Incident information: https://www.cloudflarestatus.com/incidents/qz5m74q8q0jl

    No cloud vps servers are affected.

    We apologize for the inconvenience and will share an update once we have more information.

  • Resolved
    December 16, 2021 at 9:05 PM

    Issue has been identified and fixed. We will continue to monitor the situation to make sure issue is fully resolved. Thank you for your patience throughout this process. And if you continue to experience problems, then please open a ticket with our support team.